I installed the kavlico oil pressure sensor supplied by dynon on my turbo 914 turbo engine. (p / n 101693-000)
With skyview classic, I entered the model number on the sensor screen. When I start the engine, the pressure rises in a fraction of a second and an "X" appears on the widget of the oil pressure. I plugged in the wires as shown on page 7-50 of the dynon installation manual. Does anyone have any idea where the problem came from?

Thanks

Views: 30

Reply to This

New from Zenith:

Zenith Planes For Sale 
 

Classified listing for buying or selling your Zenith building or flying related stuff...

                                                     

Weather Maps


Custom Instrument Panels
for your Zenith
:

Custom instrument panels are now available directly from Zenith Aircraft Company exclusively for Zenith builders and owners. Pre-cut panel, power distribution panel, Approach Fast Stack harnesses, Dynon and Garmin avionics, and more.


Custom Upholstery Kits for your Zenith Aircraft:

Zenith Vinyl Upholstery Kits


Zenith Apparel from EAA:


Zenair Floats


Flying On Your Own Wings:
A Complete Guide to Understanding Light Airplane Design, by Chris Heintz


Builder & Pilot Supplies:

How to videos from HomebuiltHELP.com

Developed specifically for Zenith builders (by a builder) these videos on DVD are a great help in building your own kit plane by providing practical hands-on construction information. Visit HomebuiltHelp.com for the latest DVD titles.

 

West Coast USA:

Transition Training:

Wheels & Wings

Pro Builder Assistance


 

Aircraft Spruce & Specialty for all your building and pilot supplies!

© 2019   Created by Zenith.Aero.   Powered by

Badges  |  Report an Issue  |  Terms of Service