After 200+ trouble-free hours, a couple of days ago, when I reduced power in my CH750/Jab 3300, the tachometer (GRT EIS 6000) went to zero! After landing, I discovered it would read zero below 1600 rpm and work normally at higher rpm's.

I contacted GRT and support said this is usually a sign of corrosion in the terminal connection where the Jab's alternator wires terminate (and that's where the pick-up for the tach wire is, too.)

Upon inspecting the connection, the protective plastic wire loom was very slightly melted in a an area about the size of a dime. Underneath that, the double-layer of heat shrink was slightly melted, too. After peeling all that off, the clear vinyl jacket that covers the factory-installed female spade connectors was intact, but blackened from heat at the crimp! Both connectors from the alternator were identically heat damaged. Curiously, the smaller-gauge wiring and AMP male spade connectors that I had installed looked unharmed and pristine!

I posted this on the Jabiru engine forum on Yahoo and learned this had happened to several others, too. Two things were pointed-out:

(1) The factory connectors are simply not as good as AMP connectors!

(2) In some instances, this has happened after a switch to a LiFePO4 battery!  (I switched about 25 hrs ago!) Why? It seems the Li battery has a much lower internal resistance (hence, why they have such great cranking ability!), so, when the battery is first used for a high-power requirement like cranking the engine, the alternator supplies a sudden in-rush of current to charge the battery. Supposedly the "20 amp" Jab alternator can develop up to 32 amps briefly. This rush of current over-heats the connectors.

It's been reported the more-robust AMP connectors will solve the problem. It was also recommended to delay powering-up other power-hungry systems (transponder, etc.) for a few minutes to lessen the current requirements and alternator output.

I have no idea how this would apply to other engines and electrical systems - but, just something to consider FWIW!

John

N750A

Views: 340

Reply to This

Replies to This Discussion

Thanks for the report!

I've been thinking of switching for a while, seems like an easy way to drop 10lbs off the plane.

I installed a quality, AMP connector on each lead today and all is well and my tach is back! As a precaution, I triple sleeved each connection separately with clear heat shrink (from B&C) so as to hopefully detect earlier if the problem recurs.

John

N750A

RSS

New from Zenith:

Zenith Planes For Sale 
 

Classified listing for buying or selling your Zenith building or flying related stuff...

                                                     

Weather Maps


Custom Instrument Panels
for your Zenith
:

Custom instrument panels are now available directly from Zenith Aircraft Company exclusively for Zenith builders and owners. Pre-cut panel, power distribution panel, Approach Fast Stack harnesses, Dynon and Garmin avionics, and more.


Custom Upholstery Kits for your Zenith Aircraft:

Zenith Vinyl Upholstery Kits


Zenith Apparel from EAA:


Zenair Floats


Flying On Your Own Wings:
A Complete Guide to Understanding Light Airplane Design, by Chris Heintz


Builder & Pilot Supplies:

How to videos from HomebuiltHELP.com

Developed specifically for Zenith builders (by a builder) these videos on DVD are a great help in building your own kit plane by providing practical hands-on construction information. Visit HomebuiltHelp.com for the latest DVD titles.

Aircraft Insurance:

 
 

West Coast USA:

Pro Builder Assistance
 

Pro Builder Assistance

Aircraft Spruce & Specialty for all your building and pilot supplies!

© 2019   Created by Zenith.Aero.   Powered by

Badges  |  Report an Issue  |  Terms of Service