I am having airspeed issues.  Started with have problems getting the pitot sealed up which showed low airspeed.  I have now corrected the pitot andstill have indicated speeds well below actual.

Yesterday day I recorded 80 KIAS on the Dynon D-100 while I got a speed of 96 off my GPS.  I slowed to 55 KIAS and got 80 off the GPS.  After searching the Matronic forum as well as here I see not many people are used the supplied pitot / static from Zenith which I am.  I have a Dynon D-100 using the supplied Zenith Pitot / Static probe.  With baggage lockers I have the probe under the wing just past the #5 rib which places it about 2-3 feet beyond the propeller.

With my pitot issues sealed up, I tried disconnecting the static line behind the seat and did another test run today.  This time with the static open behind the seat I had 80 KIAS and GPS @ 93 so a very slight improvement.  I slowed to 50 KIAS I have 72 on the GPS.  

I have checked my Dynon installation and don't see anything about calibration on the EFIS.  I am kind of at a loss at what to change next.  

Thanks for any and all suggestions.

Views: 548

Reply to This

Replies to This Discussion

A couple of thoughts.  Are both set to the same units? knots/mph?

I just mention that because 80 knots is 92 MPH... could be a coincidence.

Could there have been a tail wind each time?  GPS gives you ground speed, IAS gives air speed.

Any chance mud dobbers have plugged up the pito?

I know when I planned the placement of my pito I made sure to keep it away from the gas tank vents or other disturbances.  Did it read correctly in the past?

Good to hear from you again Glen.  Glad you've got the plane going again.

 

Hi

Unfortunately I have no real solution, but a few suggestions to isolate the problem.

There is a zero pressure calibration in the troubleshooting guide of the installation guide, maybe you could try that.

Is your altitude reading the same on the Dynon and your GPS at every speed/attitude/altitude? I guess if your altitude is always correct your static line must be OK. If it varies the problem is the instrument or the static line, but not the pitot.

I am not 100% sure, but I don't think it is a leak problem. A leak should be more important as pressure rise, so the difference in reading should be larger as speed increase. This is not the situation you describe. 

So if the static line is ok the problem can be the instrument or the position of the pitot.You could probably put a sleeve around the pitot to make it longer so the opening is in front of the wing, just in case there is turbulence at its current location.

If all these fail I would have a big doubt on the instrument itself. I would remove it from the airplane and test it in my car with a passenger holding a flexible hose connected to the D100 by the window,

I hope this helps...

Francois

Good catch on the Knots / MPH.   Both are in knots.  I was doing my speed checks at 4,000 feet so went up today and stayed @ 1,000.  Came up 8 lower indicated vs GPS.  For my GPS I fly 4 different heading S,E,N & W and take the average.  With the static open in the cabin I "should" get a higher indicated reading from what I have read.  

As for vents etc, nothing close as it is located in the middle of the fuel tank.  I will check the static line from the EFIS back today by blowing in the EFIS end after I disconnect it there.  I know the pitot is clear as I disconnected it at the EFIS and blew into the pitot end to confirm it was the correct line before I pumped it up to 75 PSI with a bike pump and checked for leaks.  Found no bubbles at any connections and found I lost about 2 PSI in 15 minutes.  Considering the low operating pressure I don't see that loss as an issue.  

Forgot to check the altitude today, so that is on my check list next flight.  I will also try putting a sleeve on the pitot next flight to lengthen it by about a foot which will put it about even with the leading edge.

Thanks for the tips.

I had leaks where the pitot (zenith) attaches to the rubber tubing they supply, added a brass compression union here and all fixed.  Same thing where it connected coming in from the wing to the fuselage, added 90 degree brass compression fitting all ok.  Also had to add some teflon tape where the fitting attaches to the instrument, then perfect.  Took a piece of surgical tubing and rolled it up as it was attached to the pitot tube with the EFIS on (MGL) and pinched it closed once I was at 90 MPH and it held for 10 minutes easily, then tested it at 57 MPH and worked perfectly here also.  I was amazed I had so many leaks, I thought it would all seal how they supplied it!  How did it pass the pitot static/ transponder test?

Using the Zenith supplied pitot is the source of the problem.

Spend the money for the quality Dynon pitot (unheated unless flying IFR) and your airspeed issues.

My experienced 2 cents.

Glenn,

 

I tried the test of putting a "bump" in front of, or behind, the static holes on the Zenith supplied probe to change the static pressure sensed by the ports.  I had an issue with GPS vs. indicated altitude being about 200' off at 4500msl and groundspeed vs. airspeed off by about 10 mph.  I put a few 1/4" wide wraps of speed tape in front of the static holes and then tried it behind the holes.  I can't remember now, but one exacerbated the issue and the other improved it.  I am now well under 100' of altitude and 4 mph of speed difference.  That was good enough for me and day VFR flying so I stuck with it.

 

Good luck,

 

Dave

There is a chart of pressure versus airspeed. You could use an accurate pressure gauge or manometer to ensure your indicator is calibrated correctly. ie showing correct airspeed for a couple of calibration pressures.  After that it is only a matter of getting the end of the tube to impact the air squarely ant it should be dead on. 

my 2 cents

Bob 

RSS

New from Zenith:

Zenith Planes For Sale 
 

Classified listing for buying or selling your Zenith building or flying related stuff...

                                                     

Weather Maps


Custom Instrument Panels
for your Zenith
:

Custom instrument panels are now available directly from Zenith Aircraft Company exclusively for Zenith builders and owners. Pre-cut panel, power distribution panel, Approach Fast Stack harnesses, Dynon and Garmin avionics, and more.


Custom Upholstery Kits for your Zenith Aircraft:

Zenith Vinyl Upholstery Kits


Zenith Apparel from EAA:


Zenair Floats


Flying On Your Own Wings:
A Complete Guide to Understanding Light Airplane Design, by Chris Heintz


Builder & Pilot Supplies:

How to videos from HomebuiltHELP.com

Developed specifically for Zenith builders (by a builder) these videos on DVD are a great help in building your own kit plane by providing practical hands-on construction information. Visit HomebuiltHelp.com for the latest DVD titles.

Aircraft Insurance:

 
 

West Coast USA:

Transition Training:

Pro Builder Assistance
 

Pro Builder Assistance

Aircraft Spruce & Specialty for all your building and pilot supplies!

© 2019   Created by Zenith.Aero.   Powered by

Badges  |  Report an Issue  |  Terms of Service